re = /[][:* ?\/\\]{1,}/m
str = 'Test?:? now: and a[problem] here.'
subst = '#'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result