$re = '/[][:* ?\/\\\\]{1,}/m';
$str = 'Test?:? now: and a[problem] here.';
$subst = "#";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;