#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[][:* ?\/\\]{1,}"
Local $sString = "Test?:? now: and a[problem] here."
Local $sSubst = "#"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)