use strict;
my $str = 'Test?:? now: and a[problem] here.';
my $regex = qr/[][:* ?\/\\]{1,}/mp;
my $subst = '#';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";