import Foundation
let pattern = #"^(mongodb(?:\+srv)?(\:)(?:\/{2}){1})(?:\w+\:\w+\@)?(\w+?(?:\.\w+?)*)(\:)(\d+(?:\/){0,1})(?:\/\w+?)?(?:\?\w+?\=\w+?(?:\&\w+?\=\w+?)*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// Do not work //
mongodb://username:localhost:27107/adfaeadf
mongodb://username:@localhost:27107/adfaeadf
mongodb://:password@localhost:27107/adfaeadf
mongodb://:@localhost:27107/mydatabasename
mongodb://@localhost:27107/mydatabasename
mongodb:/ddd:333/fffvv
mongodb:username:password@localhost:27107/mydatabasename
mongodb://localhost:27107fffsfsf
mongodb://localhost:27107/mydatabasename/?option=val
// should validate //
mongodb://localhost:27107/mydatabasename
mongodb://user:pass@localhost:27107/mydatabasename
mongodb://user:pass@localhost:27107/MYDATABASENAME
mongodb+srv://localhost:333/ff
mongodb://localhost:27107/mydatabasename?option=val
mongodb://localhost:27107/mydatabasename?option=val&secondOption=val
mongodb://localhost:27107
mongodb://localhost:27107/
mongodb://dbexample.com:2333
mongodb://another.example.com:2555
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)