#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(mongodb(?:\+srv)?(\:)(?:\/{2}){1})(?:\w+\:\w+\@)?(\w+?(?:\.\w+?)*)(\:)(\d+(?:\/){0,1})(?:\/\w+?)?(?:\?\w+?\=\w+?(?:\&\w+?\=\w+?)*)?$"
Local $sString = "// Do not work //" & @CRLF & _
"mongodb://username:localhost:27107/adfaeadf" & @CRLF & _
"mongodb://username:@localhost:27107/adfaeadf" & @CRLF & _
"mongodb://:password@localhost:27107/adfaeadf" & @CRLF & _
"mongodb://:@localhost:27107/mydatabasename" & @CRLF & _
"mongodb://@localhost:27107/mydatabasename" & @CRLF & _
"mongodb:/ddd:333/fffvv" & @CRLF & _
"mongodb:username:password@localhost:27107/mydatabasename" & @CRLF & _
"mongodb://localhost:27107fffsfsf" & @CRLF & _
"mongodb://localhost:27107/mydatabasename/?option=val" & @CRLF & _
"" & @CRLF & _
"// should validate //" & @CRLF & _
"mongodb://localhost:27107/mydatabasename" & @CRLF & _
"mongodb://user:pass@localhost:27107/mydatabasename" & @CRLF & _
"mongodb://user:pass@localhost:27107/MYDATABASENAME" & @CRLF & _
"mongodb+srv://localhost:333/ff" & @CRLF & _
"mongodb://localhost:27107/mydatabasename?option=val" & @CRLF & _
"mongodb://localhost:27107/mydatabasename?option=val&secondOption=val" & @CRLF & _
"mongodb://localhost:27107" & @CRLF & _
"mongodb://localhost:27107/" & @CRLF & _
"mongodb://dbexample.com:2333" & @CRLF & _
"mongodb://another.example.com:2555" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")