# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(mongodb(?:\+srv)?(\:)(?:\/{2}){1})(?:\w+\:\w+\@)?(\w+?(?:\.\w+?)*)(\:)(\d+(?:\/){0,1})(?:\/\w+?)?(?:\?\w+?\=\w+?(?:\&\w+?\=\w+?)*)?$"
test_str = ("// Do not work //\n"
"mongodb://username:localhost:27107/adfaeadf\n"
"mongodb://username:@localhost:27107/adfaeadf\n"
"mongodb://:password@localhost:27107/adfaeadf\n"
"mongodb://:@localhost:27107/mydatabasename\n"
"mongodb://@localhost:27107/mydatabasename\n"
"mongodb:/ddd:333/fffvv\n"
"mongodb:username:password@localhost:27107/mydatabasename\n"
"mongodb://localhost:27107fffsfsf\n"
"mongodb://localhost:27107/mydatabasename/?option=val\n\n"
"// should validate //\n"
"mongodb://localhost:27107/mydatabasename\n"
"mongodb://user:pass@localhost:27107/mydatabasename\n"
"mongodb://user:pass@localhost:27107/MYDATABASENAME\n"
"mongodb+srv://localhost:333/ff\n"
"mongodb://localhost:27107/mydatabasename?option=val\n"
"mongodb://localhost:27107/mydatabasename?option=val&secondOption=val\n"
"mongodb://localhost:27107\n"
"mongodb://localhost:27107/\n"
"mongodb://dbexample.com:2333\n"
"mongodb://another.example.com:2555\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.