re = /^(mongodb(?:\+srv)?(\:)(?:\/{2}){1})(?:\w+\:\w+\@)?(\w+?(?:\.\w+?)*)(\:)(\d+(?:\/){0,1})(?:\/\w+?)?(?:\?\w+?\=\w+?(?:\&\w+?\=\w+?)*)?$/m
str = '// Do not work //
mongodb://username:localhost:27107/adfaeadf
mongodb://username:@localhost:27107/adfaeadf
mongodb://:password@localhost:27107/adfaeadf
mongodb://:@localhost:27107/mydatabasename
mongodb://@localhost:27107/mydatabasename
mongodb:/ddd:333/fffvv
mongodb:username:password@localhost:27107/mydatabasename
mongodb://localhost:27107fffsfsf
mongodb://localhost:27107/mydatabasename/?option=val
// should validate //
mongodb://localhost:27107/mydatabasename
mongodb://user:pass@localhost:27107/mydatabasename
mongodb://user:pass@localhost:27107/MYDATABASENAME
mongodb+srv://localhost:333/ff
mongodb://localhost:27107/mydatabasename?option=val
mongodb://localhost:27107/mydatabasename?option=val&secondOption=val
mongodb://localhost:27107
mongodb://localhost:27107/
mongodb://dbexample.com:2333
mongodb://another.example.com:2555
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end