import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(mongodb(?:\\+srv)?(\\:)(?:\\/{2}){1})(?:\\w+\\:\\w+\\@)?(\\w+?(?:\\.\\w+?)*)(\\:)(\\d+(?:\\/){0,1})(?:\\/\\w+?)?(?:\\?\\w+?\\=\\w+?(?:\\&\\w+?\\=\\w+?)*)?$";
final String string = "// Do not work //\n"
+ "mongodb://username:localhost:27107/adfaeadf\n"
+ "mongodb://username:@localhost:27107/adfaeadf\n"
+ "mongodb://:password@localhost:27107/adfaeadf\n"
+ "mongodb://:@localhost:27107/mydatabasename\n"
+ "mongodb://@localhost:27107/mydatabasename\n"
+ "mongodb:/ddd:333/fffvv\n"
+ "mongodb:username:password@localhost:27107/mydatabasename\n"
+ "mongodb://localhost:27107fffsfsf\n"
+ "mongodb://localhost:27107/mydatabasename/?option=val\n\n"
+ "// should validate //\n"
+ "mongodb://localhost:27107/mydatabasename\n"
+ "mongodb://user:pass@localhost:27107/mydatabasename\n"
+ "mongodb://user:pass@localhost:27107/MYDATABASENAME\n"
+ "mongodb+srv://localhost:333/ff\n"
+ "mongodb://localhost:27107/mydatabasename?option=val\n"
+ "mongodb://localhost:27107/mydatabasename?option=val&secondOption=val\n"
+ "mongodb://localhost:27107\n"
+ "mongodb://localhost:27107/\n"
+ "mongodb://dbexample.com:2333\n"
+ "mongodb://another.example.com:2555\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}