re = /<([^<>\/\s]+)[^<>]*>/m
str = '<li class="ulchildlink" data-hd-product="SSEPEK_11.0.0" data-hd-operatingsystem="zOS"><span class="ulchildlinktext"><a href="../../src/tpc/n007.html?view=kc">-007</a></span><br>
STATEMENT CONTAINS THE ILLEGAL CHARACTER <var class="keyword varname ibm-item-note-alternate">invalid-character</var></li>'
subst = '<\\1>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result