const regex = /<([^<>\/\s]+)[^<>]*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<([^<>\\\/\\s]+)[^<>]*>', 'gm')
const str = `<li class="ulchildlink" data-hd-product="SSEPEK_11.0.0" data-hd-operatingsystem="zOS"><span class="ulchildlinktext"><a href="../../src/tpc/n007.html?view=kc">-007</a></span><br>
STATEMENT CONTAINS THE ILLEGAL CHARACTER <var class="keyword varname ibm-item-note-alternate">invalid-character</var></li>`;
const subst = `<\1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);