import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([^<>\\/\\s]+)[^<>]*>";
final String string = "<li class=\"ulchildlink\" data-hd-product=\"SSEPEK_11.0.0\" data-hd-operatingsystem=\"zOS\"><span class=\"ulchildlinktext\"><a href=\"../../src/tpc/n007.html?view=kc\">-007</a></span><br>\n"
+ " STATEMENT CONTAINS THE ILLEGAL CHARACTER <var class=\"keyword varname ibm-item-note-alternate\">invalid-character</var></li>";
final String subst = "<\\1>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}