# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<([^<>\/\s]+)[^<>]*>"
test_str = ("<li class=\"ulchildlink\" data-hd-product=\"SSEPEK_11.0.0\" data-hd-operatingsystem=\"zOS\"><span class=\"ulchildlinktext\"><a href=\"../../src/tpc/n007.html?view=kc\">-007</a></span><br>\n"
" STATEMENT CONTAINS THE ILLEGAL CHARACTER <var class=\"keyword varname ibm-item-note-alternate\">invalid-character</var></li>")
subst = "<\\1>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.