re = /^([a-z]+)(?:([A-Z]{1})([a-z]+))+$/m
str = 'myjfgfgffhVarBaThisVinoth
myVar
MYVAR
my-var
my.var
Myvar
My var
my var
Myvar
myvar
my Var
myVar
myVAR
myVARandV
my_var
myVarAndV
myAndVar
myV_ar
my_Var
my*Var
myV*ar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end