package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z]+)(?:([A-Z]{1})([a-z]+))+$`)
var str = `myjfgfgffhVarBaThisVinoth
myVar
MYVAR
my-var
my.var
Myvar
My var
my var
Myvar
myvar
my Var
myVar
myVAR
myVARandV
my_var
myVarAndV
myAndVar
myV_ar
my_Var
my*Var
myV*ar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}