using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z]+)(?:([A-Z]{1})([a-z]+))+$";
string input = @"myjfgfgffhVarBaThisVinoth
myVar
MYVAR
my-var
my.var
Myvar
My var
my var
Myvar
myvar
my Var
myVar
myVAR
myVARandV
my_var
myVarAndV
myAndVar
myV_ar
my_Var
my*Var
myV*ar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}