#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-z]+)(?:([A-Z]{1})([a-z]+))+$"
Local $sString = "myjfgfgffhVarBaThisVinoth" & @CRLF & _
"myVar" & @CRLF & _
"MYVAR" & @CRLF & _
"my-var" & @CRLF & _
"my.var" & @CRLF & _
"Myvar" & @CRLF & _
"My var" & @CRLF & _
"my var" & @CRLF & _
"Myvar" & @CRLF & _
"myvar" & @CRLF & _
"my Var" & @CRLF & _
"myVar " & @CRLF & _
"myVAR" & @CRLF & _
"myVARandV" & @CRLF & _
"my_var" & @CRLF & _
"myVarAndV" & @CRLF & _
"myAndVar" & @CRLF & _
"myV_ar" & @CRLF & _
"my_Var" & @CRLF & _
"my*Var" & @CRLF & _
"myV*ar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")