$re = '/^([a-z]+)(?:([A-Z]{1})([a-z]+))+$/m';
$str = 'myjfgfgffhVarBaThisVinoth
myVar
MYVAR
my-var
my.var
Myvar
My var
my var
Myvar
myvar
my Var
myVar
myVAR
myVARandV
my_var
myVarAndV
myAndVar
myV_ar
my_Var
my*Var
myV*ar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);