re = /\S*_((?!en)\S{2,3}(-\S{2,3})?)\.properties/
str = '# Don\'t match default language files
labels_en.properties
labels_en-EN.properties
# Match other languages files
labels_fr.properties
labels_fr-FR.properties
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end