import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S*_((?!en)\\S{2,3}(-\\S{2,3})?)\\.properties";
final String string = "# Don't match default language files\n"
+ "labels_en.properties\n"
+ "labels_en-EN.properties\n"
+ "# Match other languages files\n"
+ "labels_fr.properties\n"
+ "labels_fr-FR.properties\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}