$re = '/\S*_((?!en)\S{2,3}(-\S{2,3})?)\.properties/';
$str = '# Don\'t match default language files
labels_en.properties
labels_en-EN.properties
# Match other languages files
labels_fr.properties
labels_fr-FR.properties
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);