using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S*_((?!en)\S{2,3}(-\S{2,3})?)\.properties";
string input = @"# Don't match default language files
labels_en.properties
labels_en-EN.properties
# Match other languages files
labels_fr.properties
labels_fr-FR.properties
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}