#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\S*_((?!en)\S{2,3}(-\S{2,3})?)\.properties"
Local $sString = "# Don't match default language files" & @CRLF & _
"labels_en.properties" & @CRLF & _
"labels_en-EN.properties" & @CRLF & _
"# Match other languages files" & @CRLF & _
"labels_fr.properties" & @CRLF & _
"labels_fr-FR.properties" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")