// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\S]*) {2,}([\p{L}\p{Nd}\w- \<\>\[\]\&\$\/\*\+\,\'\:\(\)\.!#\?=%]*)").unwrap();
let string = "PART-TIME Yarı zamanlı
FULL-TIME Tam zamanlı
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}