package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\S]*) {2,}([\p{L}\p{Nd}\w- \<\>\[\]\&\$\/\*\+\,\'\:\(\)\.!#\?=%]*)`)
var str = `PART-TIME Yarı zamanlı
FULL-TIME Tam zamanlı
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}