// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sxmu)[*\s]*@(?P<name>[\w\\]+)\s*\(?(?P<value>(?:[^@]*[^*\s/)]))?(?:\s|$|\))").unwrap();
let string = "/**
* Headline
*
* Desciption
* On multiple
* Lines
*
* @test ett
* @igen tvÄ
*/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}