re = /[*\s]*@(?P<name>[\w\\]+)\s*\(?(?P<value>(?:[^@]*[^*\s\/)]))?(?:\s|$|\))/xm
str = '/**
* Headline
*
* Desciption
* On multiple
* Lines
*
* @test ett
* @igen tvÄ
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end