using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[*\s]*@(?P<name>[\w\\]+)\s*\(?(?P<value>(?:[^@]*[^*\s/)]))?(?:\s|$|\))";
string input = @"/**
* Headline
*
* Desciption
* On multiple
* Lines
*
* @test ett
* @igen tvÄ
*/";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}