#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sxmu)[*\s]*@(?P<name>[\w\\]+)\s*\(?(?P<value>(?:[^@]*[^*\s/)]))?(?:\s|$|\))"
Local $sString = "/**" & @CRLF & _
" * Headline" & @CRLF & _
" * " & @CRLF & _
" * Desciption" & @CRLF & _
" * On multiple" & @CRLF & _
" * Lines" & @CRLF & _
" *" & @CRLF & _
" * @test ett" & @CRLF & _
" * @igen tvÄ" & @CRLF & _
" */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")