$re = '%[*\s]*@(?P<name>[\w\\\\]+)\s*\(?(?P<value>(?:[^@]*[^*\s/)]))?(?:\s|$|\))%sxmu';
$str = '/**
* Headline
*
* Desciption
* On multiple
* Lines
*
* @test ett
* @igen tvÄ
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);