// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^s:([0-9a-f]{64})[\s\S].*$").unwrap();
let string = "XSRF-TOKEN=s%3A7faa4cc0b1e4bdce39bd46f8d96bf2c17c2aba158d3e4a4d219eb7295045ad74.m%2FjbawJSNaVIurcgVICYzA26lN2%2FvGUa5sU8Bc1fA0k";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}