import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^s:([0-9a-f]{64})[\\s\\S].*$";
final String string = "XSRF-TOKEN=s%3A7faa4cc0b1e4bdce39bd46f8d96bf2c17c2aba158d3e4a4d219eb7295045ad74.m%2FjbawJSNaVIurcgVICYzA26lN2%2FvGUa5sU8Bc1fA0k";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}