using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^s:([0-9a-f]{64})[\s\S].*$";
string input = @"XSRF-TOKEN=s%3A7faa4cc0b1e4bdce39bd46f8d96bf2c17c2aba158d3e4a4d219eb7295045ad74.m%2FjbawJSNaVIurcgVICYzA26lN2%2FvGUa5sU8Bc1fA0k";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}