$re = '/^s:([0-9a-f]{64})[\s\S].*$/';
$str = 'XSRF-TOKEN=s%3A7faa4cc0b1e4bdce39bd46f8d96bf2c17c2aba158d3e4a4d219eb7295045ad74.m%2FjbawJSNaVIurcgVICYzA26lN2%2FvGUa5sU8Bc1fA0k';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);