# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^s:([0-9a-f]{64})[\s\S].*$"
test_str = "XSRF-TOKEN=s%3A7faa4cc0b1e4bdce39bd46f8d96bf2c17c2aba158d3e4a4d219eb7295045ad74.m%2FjbawJSNaVIurcgVICYzA26lN2%2FvGUa5sU8Bc1fA0k"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.