re = /(?:[\(\)eA-Z][a-z]*(?:_\{? ?\d*\}?(?:(?:_\d)?)*)?)+(?:\^\{? ?\d*[\+-]?\}?)?/
str = 'H_2O
C_5H_12
Pb(NO_3)_2
H_2O \\rightarrow O_2 + H^{1+} + e^-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end