package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[\(\)eA-Z][a-z]*(?:_\{? ?\d*\}?(?:(?:_\d)?)*)?)+(?:\^\{? ?\d*[\+-]?\}?)?`)
var str = `H_2O
C_5H_12
Pb(NO_3)_2
H_2O \rightarrow O_2 + H^{1+} + e^-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}