$re = '/(?:[\(\)eA-Z][a-z]*(?:_\{? ?\d*\}?(?:(?:_\d)?)*)?)+(?:\^\{? ?\d*[\+-]?\}?)?/';
$str = 'H_2O
C_5H_12
Pb(NO_3)_2
H_2O \\rightarrow O_2 + H^{1+} + e^-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);