const regex = new RegExp('(?:[\\(\\)eA-Z][a-z]*(?:_\\{? ?\\d*\\}?(?:(?:_\\d)?)*)?)+(?:\\^\\{? ?\\d*[\\+-]?\\}?)?', 'g')
const str = `H_2O
C_5H_12
Pb(NO_3)_2
H_2O \\rightarrow O_2 + H^{1+} + e^-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}