import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\(\\)eA-Z][a-z]*(?:_\\{? ?\\d*\\}?(?:(?:_\\d)?)*)?)+(?:\\^\\{? ?\\d*[\\+-]?\\}?)?";
final String string = "H_2O\n"
+ "C_5H_12\n"
+ "Pb(NO_3)_2\n"
+ "H_2O \\rightarrow O_2 + H^{1+} + e^-";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}