import Foundation
let pattern = #"(=|\+|-|:)+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"==GFTX=BL2++UMB01+MPDP01+00010-PIO01:04"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)