# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(=|\+|-|:)+/_/g;t' <<< "==GFTX=BL2++UMB01+MPDP01+00010-PIO01:04"