const regex = /(=|\+|-|:)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(=|\\+|-|:)+', 'g')
const str = `==GFTX=BL2++UMB01+MPDP01+00010-PIO01:04`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);