$re = '/(=|\+|-|:)+/';
$str = '==GFTX=BL2++UMB01+MPDP01+00010-PIO01:04';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;