package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(=|\+|-|:)+`)
var str = `==GFTX=BL2++UMB01+MPDP01+00010-PIO01:04`
var substitution = "_"
fmt.Println(re.ReplaceAllString(str, substitution))
}