const regex = /\$\(['|"](.[^\)]*)['|"]\)\.addClass\(['|"]btnDisabled['|"]\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\([\'|"](.[^\\)]*)[\'|"]\\)\\.addClass\\([\'|"]btnDisabled[\'|"]\\)', 'gm')
const str = `\$('#btn-new-reg, #btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-prev-field, #btn-next-field').addClass('btnDisabled')
// código entre o que me interessa
\$("#btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-next-field").addClass("btnDisabled")
\$("#btn-save-reg, #btn-del-reg, #btn-prev-reg, #btn-next-reg, #btn-next-field").removeClass("btnDisabled")
\\\$\\(['|"](.[^\\)]*)['|"]\\)\\.addClass\\(['|"]btnDisabled['|"]\\)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}