import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\(['|\"](.[^\\)]*)['|\"]\\)\\.addClass\\(['|\"]btnDisabled['|\"]\\)";
final String string = "$('#btn-new-reg, #btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-prev-field, #btn-next-field').addClass('btnDisabled')\n\n"
+ "// código entre o que me interessa \n\n"
+ "$(\"#btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-next-field\").addClass(\"btnDisabled\")\n\n\n"
+ "$(\"#btn-save-reg, #btn-del-reg, #btn-prev-reg, #btn-next-reg, #btn-next-field\").removeClass(\"btnDisabled\")\n\n"
+ "\\$\\(['|\"](.[^\\)]*)['|\"]\\)\\.addClass\\(['|\"]btnDisabled['|\"]\\)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}