package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$\(['|"](.[^\)]*)['|"]\)\.addClass\(['|"]btnDisabled['|"]\)`)
var str = `$('#btn-new-reg, #btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-prev-field, #btn-next-field').addClass('btnDisabled')
// código entre o que me interessa
$("#btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-next-field").addClass("btnDisabled")
$("#btn-save-reg, #btn-del-reg, #btn-prev-reg, #btn-next-reg, #btn-next-field").removeClass("btnDisabled")
\$\(['|"](.[^\)]*)['|"]\)\.addClass\(['|"]btnDisabled['|"]\)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}