using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\(['|""](.[^\)]*)['|""]\)\.addClass\(['|""]btnDisabled['|""]\)";
string input = @"$('#btn-new-reg, #btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-prev-field, #btn-next-field').addClass('btnDisabled')
// código entre o que me interessa
$(""#btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-next-field"").addClass(""btnDisabled"")
$(""#btn-save-reg, #btn-del-reg, #btn-prev-reg, #btn-next-reg, #btn-next-field"").removeClass(""btnDisabled"")
\$\(['|""](.[^\)]*)['|""]\)\.addClass\(['|""]btnDisabled['|""]\)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}