#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$\(['|"](.[^\)]*)['|"]\)\.addClass\(['|"]btnDisabled['|"]\)"
Local $sString = "$('#btn-new-reg, #btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-prev-field, #btn-next-field').addClass('btnDisabled')" & @CRLF & _
"" & @CRLF & _
"// código entre o que me interessa " & @CRLF & _
"" & @CRLF & _
"$("#btn-save-reg, #btn-del-reg, #btn-adv-search, #btn-prev-reg, #btn-next-reg, #btn-next-field").addClass("btnDisabled")" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"$("#btn-save-reg, #btn-del-reg, #btn-prev-reg, #btn-next-reg, #btn-next-field").removeClass("btnDisabled")" & @CRLF & _
"" & @CRLF & _
"\$\(['|"](.[^\)]*)['|"]\)\.addClass\(['|"]btnDisabled['|"]\)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")